Excel WENNFEHLER-Funktion

Startseite>>Microsoft>>Office>>Excel>>Excel WENNFEHLER-Funktion

Die Wennfehler-Funktion macht es in Excel möglich, Fehlerausgaben abzufangen und sie durch etwas anderes zu ersetzen. Natürlich gibt es immer noch die Funktion Istfehler, aber diese wird meistens zusammen mit einer Wenn-Funktion verwendet. Dank Wennfehler kann man sich das Verschachteln in einer Wenn-Funktion sparen.

 

Ohne Wennfehler-Funktion: Fehlermeldung

In unserem Beispiel wollen wir einfach eine Zahl teilen. Hier soll also das Ergebnis (Spalte A) durch die Anzahl (Spalte B) geteilt werden.

Beispiel ohne Wennfehler

Da die Zelle B4 eine Zahl enthält, kann in C4 die Formel =A4/B4 rechnen und 12,5 ausgeben.

In B7 ist die Zelle leer. Also ergibt die Formel =A7/B7 in C7 die Fehlermeldung #DIV/0, da hier versucht wird, durch nichts zu teilen, was mathematisch nicht möglich ist.

Mit Wennfehler-Funktion: gewünschte Ausgabe

Die Wennfehler-Funktion hilft uns hier, das Problem zu lösen. Sie hat immer 2 Argumente:

WENNFEHLER( Wert ; Wert falls Fehler )

Wert: dieses Argument wird ausgegeben, wenn es keinen Fehler ergibt.
(hier: A12/B12 bzw. A15/B15)

Wert falls Fehler: wird ausgegeben, wenn das „Wert“-Argument einen Fehler ergibt.

In C12 und C15 benutzen wir also Folgendes:

C12:

=WENNFEHLER(A12/B12;"Bitte eingeben")

C15:

=WENNFEHLER(A15/B15;"Bitte eingeben")

Beispiel mit Wennfehler

Beispiel herunterladen

Artikel bewerten

Excel WENNFEHLER-Funktion
Artikel bewerten
4.19 Sternen
21 Stimmen
Finden Sie den Artikel „Excel Wennfehler“ hilfreich? Dann hinterlassen Sie uns einen Kommentar, oder bewerten Sie ihn.

2016-12-25T10:14:02+00:00 03.10.16|Excel, Microsoft, Office|0 Comments

Hinterlassen Sie einen Kommentar