Die Vergleich-Funktion macht es in Excel möglich herauszufinden, welche Position eine Zeichenfolge oder ein Wert in einer Matrix hat. Dabei gibt uns die Vergleich-Funktion eine Zahl aus. Diese Zahl steht für die Spaltenposition oder für die Zeilenposition innerhalb der Matrix.

Wer schon mit Matrix-Funktionen wie Sverweis oder Wverweis gearbeitet hat, wird mit der Vergleich-Funktion eine neue Dynamik entdecken: während die Sverweis-Funktion nur nach einem Suchkriterium sucht, kann man mit einer Kombination aus Index-Funktion und Vergleich-Funktion viel mehr erreichen.

Dieser Artikel ist Teil einer Trilogie:

  1. Vergleich-Funktion
  2. Index-Funktion
  3. Index- und Vergleich-Funktion kombinieren

Unser Beispiel zur Vergleich-Funktion:

Diese Tabelle (A1 bis D6) enthält Spaltenbezeichnungen (Jan, Feb, Mrz) UND Zeilenbezeichnungen (Warp Antrieb, Darth Vader Helm, …). Deshalb handelt es sich hier um eine Matrix.

Wir wollen mit 2 Vergleich-Funktionen herausfinden:

  • in der wievielten Spalte der Matrix sich die Zeichenfolge „Mrz“ befindet und
  • in der wievielten Zeile der Matrix sich die Zeichenfolge „Laserschwert“ befindet
Beispiel herunterladen

Spalten mit der Vergleich-Funktion durchsuchen:

Excel - Vergleich-Funktion - Spalten

Sie wollen, dass Excel in der Zelle B9 eine 4 ausgibt, weil die Zeichenfolge „Mrz“ sich in der 4. Spalte der Matrix befindet. Dafür klicken Sie die Zelle B9 und geben Folgendes ein:

=VERGLEICH(A9;A1:D1;0)

Drücken Sie die ENTER-Taste und Excel gibt Ihnen eine 4 aus. Wenn Sie in der Zelle A9 z.B. „Jan“ schreiben, wird Ihnen Excel eine 2 ausgeben.

Die Vergleich-Funktion hat 3 Argumente:

  • Suchkriterium (A9): dadurch erfährt Excel, wonach gesucht wird. In unserem Beispiel wird nach „Mrz“ gesucht, weil in der Zelle A9 „Mrz“ eingetragen ist
  • Suchmatrix (A1:D1): das ist der Bereich, in dem nach dem Suchkriterium gesucht wird
  • Vergleichtstyp (0): Den Vergleichstyp kann man sich wie einen Schalter vorstellen, der 3 Position hat: -1, 0 oder 1
    Wir haben hier eine 0 eingegeben. Das bedeutet, dass die VERGLEICH-Funktion nach dem ersten Wert suchen wird, der mit dem Suchkriterium genau übereinstimmt.

Zeilen mit der Vergleich-Funktion durchsuchen:

Excel - Vergleich-Funktion - Zeilen

Sie wollen, dass Excel in der Zelle B10 eine 6 ausgibt, weil sich die Zeichenfolge „Laserschwert“ in der 6. Zeile der Matrix befindet. Dafür klicken Sie die Zelle B10 und geben Folgendes ein:

=VERGLEICH(A10;A1:A6;0)

Drücken Sie die ENTER-Taste und Excel gibt Ihnen eine 6 aus. Wenn Sie in der Zelle A10 z.B. „Warp Antrieb“ schreiben, wird Ihnen Excel eine 2 ausgeben.

Die Vergleich-Funktion hat 3 Argumente:

  • Suchkriterium (A10): dadurch erfährt Excel, wonach gesucht wird. In unserem Beispiel wird nach „Laserschwert“ gesucht, weil in der Zelle A10 „Laserschwert“ eingetragen ist
  • Suchmatrix (A1:A6): das ist der Bereich, in dem nach dem Suchkriterium gesucht wird
  • Vergleichtstyp (0): Den Vergleichstyp kann man sich wie einen Schalter vorstellen, der 3 Position hat: -1, 0 oder 1
    Wir haben hier eine 0 eingegeben. Das bedeutet, dass die VERGLEICH-Funktion nach dem ersten Wert suchen wird, der mit dem Suchkriterium genau übereinstimmt.

SIE HABEN NOCH FRAGEN ?

FORUM

Artikel bewerten

Finden Sie den Artikel „Excel VERGLEICH-Funktion am Beispiel erklärt“ hilfreich? Dann hinterlassen Sie uns einen Kommentar, oder bewerten Sie ihn.